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General Safety Summary 

Review the following safety precautions to avoid injury and prevent damage to 
this product or any products connected to it. To avoid potential hazards, use this 
product only as specified. 

Only qualified personnel should perform service procedures. 

While using this product, you may need to access other parts of the system. Read 
the General Safety Summary in other system manuals for warnings and cautions 
related to operating the system. 

To Avoid Fire or Personal Injury: 

Connect and Disconnect Properly: Do not connect or disconnect probes or test 
leads while they are connected to a voltage source. 

Observe All Terminal Ratings: To avoid fire or shock hazard, observe all 
ratings and markings on the product. Consult the product manual for further 
ratings information before making connections to the product. 

Do Not Operate With Suspected Failures: If you suspect there is damage to 
this product, have it inspected by qualified service personnel. 

Symbols and Terms: The following terms and symbols may appear in the online 
help. 

 WARNING. Warning statements identify conditions or practices that could 
result injury or loss of life.    

 

 CAUTION. Caution statements identify conditions or practices that could 
result in damage to this product or other property.    
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Terms on the Product: The following terms may appear on the product: 

� DANGER indicates an injury hazard immediately accessible as you read the 
marking. 

� WARNING indicates an injury hazard not immediately accessible as you 
read the marking. 

� CAUTION indicates a hazard to property including the product. 

 

Symbols on the Product: The following symbol(s) may appear in the product: 

 CAUTION  
Refer to Help 
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Preface 

Welcome to the TDSCPM2 Communication Pulse Measurements Application. 

 

Figure 1: TDSCPM2 Communication Pulse Measurements Application 

 

The TDSCPM2 Communications Pulse Measurements Application enhances 
basic capabilities of some Tektronix communications oscilloscopes. 

The application provides pulse-and-eye-mask pattern, spectral power, pulse 
amplitude, and pulse balance testing for data rates defined in the ITU-T-G.703 
and ANSI T1.102 communications standards. 

The application also: 

� Increases efficiency in performing compliance measurements 

� Displays the results as Pass/Fail indicators 

� Saves the results to a data log file 

� Facilitates remote automation 

  

Using Online Help 
A help file has many advantages over a printed manual because of the advanced 
searching capabilities. Selecting Help on the right side of the application's Menu 
bar or pressing F-1 function key brings up the help file. The main (opening) Help 
screen is divided into three folders, each of which offers a unique mode of 
assistance. 
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� Table of Contents (TOC) - organizes the Help into book-like sections. 
Click books to open and select topics of interest. 

� Index - enables you to scroll a list of alphabetical keywords. Click the topic 
of interest to bring up the appropriate help page. 

� Find - allows a text-based search. Follow the steps below: 

1. Type the word or phrase you want to find in the search box. 

2. Select some matching words in the next box to narrow your search. 

3. Choose a topic in the lower box, and then select the Display button. 

� To print a topic, select the Print button from the help topics menu bar. 
(To print color example screens, see Color Printing.) 

� Select Options from the menu bar for other commands, such as to 
annotate a topic, keep the help window on top or to use system colors. 

� Select the Back button to return to the previous help window. 
Sometimes you can jump from one topic to another through a 
hyperlink. If the Back button is "grayed out" or a jump is not available, 
choose the "Help Topics" button to return to the originating help folder.  

� Sometimes you will see a bolded "Note" in topic text. This indicates 
that very important (noteworthy) information is being imparted to the 
user.  

Certain aspects of the online help are unique to applications that run on the 
oscilloscope.  

Pop-up text is green (with no underlines). Select the green text to display a brief 
help message. Click to return to the topic. 

Note: Green-underlined text indicates a Jump (hyperlink) to another topic. Select 
the green text to jump to the related topic. For example, click the green text to 
jump to the topic on Online Help and Related Documentation. 
 

 You can tell when the cursor is over an active hyperlink (button, jump, or 
popup), because the cursor "arrow" changes to a small "hand". 

 
Note the light bulb and word Tip in the graphic above. This graphic indicates that 
additional information is being provided to help you function faster or more 
efficiently. 
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Color Printing 
Some online help topics have color in the examples of the displayed application. 
If you want to print this type of topic on a monochrome printer, some 
information may not print because of certain colors. Instead, you should print the 
topic from PDF (portable document format) file that corresponds to the Online 
Help. You can find the file in the Documents directory on the Optional 
Applications Software on a Windows-Based Oscilloscope CD. The figures of 
application menus in the PDF file are gray scale and all of the information prints. 

Related Documentation 
 

In addition to the Online Help, you can access other information on how to 
operate the oscilloscope and application through the following related 
documents: 

� Quick Reference; the application-specific quick reference contains a "mini" 
tutorial and a menu map that shows the structure of the user interface.  

� Installation Instructions; the installation instructions provide information on 
how to install software. 

� Oscilloscope Information; the user manual for your oscilloscope provides 
general information on how to operate the oscilloscope. 

� Programmer Information; the online help for your oscilloscope provides 
details on how to use GPIB commands to control the oscilloscope. 

� The ITU-T Recommendation G.704 (07/95), General Aspects of Digital 
Transmission Systems, document provides information on the ITU-T-G.703 
standard. 

� The American National Standard for Telecommunications--Digital 
Hierarchy--Electrical Interfaces document provides information on the 
ANSI T1.102 standard. 

Refer to the Optional Applications Software on a Windows-Based Oscilloscope 
Installation Manual for the following information: 

� Software warranty 

� List of all available applications, compatible instruments, and relevant 
software and firmware version numbers 

� Applying a new label 

� Installing an application 
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� Enabling an application 

� Downloading updates from the Tektronix Web site 

You can find a PDF (portable document format) file for this document in the 
Documents directory on the Optional Applications Software on a Windows-
Based Oscilloscope CD. The CD booklet only contains information on installing 
the application from the CD and on how to apply a new label. 

Conventions 
Online help uses the following conventions: 

� This online help refers to the TDSCPM2 Communications Pulse 
Measurements Application as the TDSCPM2 application or as the 
application. 

� When steps require a sequence of selections using the application interface, 
the ">" delimiter marks each transition between a menu and an option. For 
example, one of the steps to recall a setup file would appear as 
Measurements > Save/Recall > Recall. 
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Feedback 
Tektronix values your feedback on our products. To help us serve you better, 
please send us suggestions, ideas, or other comments you may have regarding 
your oscilloscope. 

Direct your feedback to us through email to techsupport@tektronix.com and 
include the following information. Please be as specific as possible. 

General information: 

� Oscilloscope model number and hardware options, if any 

� Probes used 

� Your name, company, mailing address, phone number, FAX number 

� Please indicate if you would like to be contacted by Tektronix regarding 
your suggestion or comments 

Application specific information: 

� Software version number 

� Description of the problem such that technical support can duplicate the 
problem 

� If possible, save the oscilloscope and application setup files as .set, .ini, and 
.wfm files 

� If possible, save the oscilloscope and application setup files from the 
application to obtain both the scope .set file and the application .ini file. 

Once you have gathered this information, you can contact technical support by 
phone or through e-mail. If using e-mail, be sure to enter in the subject line 
"TDSCPM2 Problem," and attach the .set, .ini, and .wfm files. 

To include screen shots, from the oscilloscope menu bar, select File > 
Export…. The Export Dialog box displays. Enter a file name with a .bmp 
extension and Save. You can then attach the file to your email (depending on the 
capabilities of your email editor). 

TDSCPM2 Communication Pulse Measurements Application                                                                               xi 
 



 
Preface 

 

 

  
 

xii       TDSCPM2 Communication Pulse Measurements Application 
 



 

 

Getting Started  

The TDSCPM2 Communications Pulse Measurements Application is a  
Java™–based application that augments general capabilities of select Tektronix 
Oscilloscopes. The application provides pulse parametric and eye pattern, 
spectral power, pulse amplitude, and pulse balance testing for data rates defined 
in the ITU–T G.703 and ANSI T1.102 communications standards.  

The next figure shows an example of a pulse-mask pattern, a communications 
signal, and the results readout. 

 

 
Figure 2: Communications Pulse Measurements Application  
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Compatibility 
For information on compatibility, refer to the Optional Application Software on 
Windows-Based Oscilloscopes Installation Manual. The manual is available on 
the Optional Application Software on Windows-Based Oscilloscopes CD.  

Requirements and Restrictions 
The Sun Java Run-Time Environment V1.4.2 is automatically installed on the 
oscilloscope to operate the TDSCPM2 application and use the GPIB commands. 

Standard Accessories 
There are no standard accessories for this product. 

Optional Accessories 
The AFTDS Differential Signal Adapter and the AMT75 75/50 Ω Adapter (5x) 
are accessories that you can use with this product. 

Installation 
Refer to the Optional Applications Software on a Windows-Based Oscilloscope 
Installation Manual for the following information: 

� Software Warranty 

� List of applications, compatible instruments, and relevant software and 
firmware version numbers 

� Applying a new label 

� Installing an application 

� Enabling an application 

� Download updates from the Tektronix Web site 

If you need to locate the corresponding Portable Document Format (PDF) file of 
this document, you can find it in the Documents directory on the Optional 
Applications Software on a Windows-Based Oscilloscope CD. The CD booklet 
only contains information on installing the application from the CD and on how 
to apply a new label. 
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Connecting to a System Under Test 
You can use an AFTDS or AMT75 electrical communication adapter to connect 
between your System Under Test (SUT) and the oscilloscope. These adapters 
match the output signal from 75 ohms to 50 ohms. 

Note: Input impedance to the instrument must be 50 ohms. 
 

To connect the electrical communication adapter between the SUT and the 
oscilloscope, refer to the figure below and follow these steps: 

 WARNING. To avoid electric shock, you must ensure that power is removed 
from the SUT before attaching a probe to it. Do not touch exposed conductors 
except with the properly rated probe tips. Refer to the probe manual for 
proper use. 

 

 

 

1. Power off the SUT.  

2. Connect the AFTDS or AMT75 electrical communication adapter to CH 1 
of the oscilloscope.  

3. Connect the electrical communication adapter to the appropriate 
communication signal in the SUT. 

 

 
Figure 3: Connecting to a system under test 

Note: If you are using a TekConnect™ version of high performance 
oscilloscopes, a TCA-BNC adapter is required. For DPO7000 series 
oscilloscopes, use TPA-BNC adapter. 
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Operating Basics 

This section contains information on the following topics and tasks: 

� Application interface 

� Using basic oscilloscope functions 

� Setting up the application 

� Taking measurements 

� Analyzing the results 

� Saving the results to a file 

� Saving and recalling setups 

� Exiting the application 

 

Application Interface 
The application uses a Windows interface.  

Note: The oscilloscope application shrinks to half size and appears in the top 
half of the display when the application is running. If the application is running 
but hidden from view, select the App button or Restore application menu on the 
screen to return it to view. 
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 Table 1: Application Interface Menu Controls 

Item Description 
Menu bar Located at the top of the application display and 

contains application menus 
Area Visual frame that encloses a set of related options 
Option button Button that defines a particular command or task 
List box Box that contains a list of items from which you can 

select one item 
Box Box that you can use to type in text, or to enter a 

value with the keypad or a multipurpose knob 
Scroll bar Vertical or horizontal bar at the side or bottom of a 

display area that can be used for moving around in 
that area 

Browse Displays a window where you can look through a list 
of directories and files 

Command 
button 

Button that initiates an immediate action 

 
 

Running the Application 
Depending on the type of oscilloscope that you have, you can start the software 
in one of the following ways: 

� Select File > Run application in the oscilloscope menu bar. Then select 
Communications Pulse Measurements 2. 

� Select App > Communications Pulse Measurements 2. 

� Select Analyze > Communications Pulse Measurements 2. 

Minimizing and Maximizing the Application 
The application remains displayed when you minimize the instrument. To 
minimize the application, select File > Minimize. 

The way you maximize the application depends on the oscilloscope model. To 
maximize the application, do one of the following: 

� Select TDSCPM2 in the Windows toolbar. 

� Select the App > Restore Application on the oscilloscope menu bar. 

� Select the Analyze > Restore Application on the oscilloscope menu bar. 
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� Click the App button on the top right of the oscilloscope. 

 

Figure 4: File Menu 

 

Hiding and Returning to the Application 
When you access oscilloscope functions, the oscilloscope fills the display. You 
can access oscilloscope functions in the following ways:  

� Select the Hide button in the application display 

� Choose the Menu-bar or Toolbar mode on the oscilloscope and access 
menus 

To return to the application, choose the App button on the top menu bar of the 
TDS oscilloscope. 

To return to the application, choose Analyze > Restore Application on the DPO 
oscilloscope. 

Exiting the application 
To exit the application, choose File > Exit or the Exit button in the lower right 
corner of the application. When you exit the application, you can select to keep 
the oscilloscope setup currently in use with the application or to restore the 
oscilloscope setup that was present before you started the application. 
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Application Directories and File Names 
The application uses directories to save and recall setup files and uses extensions 
appended to file names to identify the file type. 

The next table lists default directory names. 

Table 2: Default Directory Names 

Directory                                                        Used for 
C:\TekApplications\tdscpm2 Home location 
C:\TekApplications\tdscpm2\logs Data log files 
C:\TekApplications\tdscpm2\setup Setup files 
 

Table 3: File Name Extensions 

Extension Type 
.csv Log file that uses a “comma separated variable” format 
.ini Application setup file 
.set Oscilloscope setup file saved and recalled with an .ini file; both 

files will have the same name 
 

 

Setting Up the Application to Take Measurements 
You can set up the application to take measurements for data rates defined in the 
ITU-T G.703 and ANSI T1.102 communications standards, and to display the 
results or save them to a data log file.  

There are two Measurements menus. One allows you to select and the other to 
configure a measurement. 
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 Table 4: ITU-T G.703 Data Rates and Tests 

Test E1, 
both 

E2 E3 E4 STM–1E 

Pulse Amplitude Yes Yes Yes - - - - - - 
Peak–Peak - - - - - - - - - Yes Yes 
Pulse Symmetry Yes Yes Yes - - - - - - 
Zero Level Yes Yes Yes - - - - - - 
Mask Yes Yes Yes Yes Yes 

  

 Table 5: ANSI T1.102 Data Rates and Tests 

Test DS1 DS3 DS4NA STS–1 STS–3 
Pulse Amplitude Yes Yes - - - - - - - - - 
Pulse Imbalance: 
Variation 

Yes - - - - - - - - - - - - 

Pulse Imbalance:  
Ratio 

- - - Yes - - - - - - - - - 

Spectral Power Yes Yes Yes Yes Yes 
Mask Yes Yes Yes Yes Yes 

  
  

  
Figure 5: ITU G.703 Measurement Selections 
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Selecting Measurements 

 

Table 6: Data Rate Menu Options for ITU-T G.703 Standard 

Option Description*
E1 2.048 Mb/s Coax Pair Signal defined in Section 9, Table 7, and

Figure 15 medium, 75 Ohm coaxial pair
E1 2.048 Mb/s Sym Pair Signal defined in Section 9, Table 7, and

Figure 16 medium, 120 Ohm symmetrical pair
E2 8.448 Mb/s Signal defined in Section 10, Table 8, and

Figure 16
E3 34.368 Mb/s Signal defined in Section 11, Table 9, and

Figure 17
E4 139.26 Mb/s Signal defined in Section 12, Table 10, Figure

19, and Figure 20
STM–1E 155.52 Mb/s Signal defined in Section 15, Table 12, Figure

22, and Figure 23
*  Found in ITU–T G.703, the ITU–T Recommendation G.704 (07/95),
General Aspects of Digital Transmission Systems printed in October 1998
** Found in ITU–T G.703 printed in 1991

 

Table 7: Data Rate Menu Options for ANSI T.102 Standard 

Option Description* 
DSI 1.544 Mb/s Signal defined in Section 6.1, Table 1, and 

Figure 1 
DS3 44.736 Mb/s Signal defined in Section 6.4, Table 4, and 

Figure 4 
DS4NA 139.26 Mb/s Signal defined in Section 6.6, Table 6, Figure 

7, and Figure 8 
STS–1 51.840 Mb/s Signal defined in Section 6.5, Table 5, and 

Figure 5 
STS–3 155.52 Mb/s Signal defined in Section 6.7, Table 7, Figure 

9, and Figure 10 
* Found in ANSI T1.102–1993, the American National Standard for 
Telecommunications - Digital Hierarchy - Electrical Interfaces 
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  Figure 6: Measurements Select Menu, ANSI 

 
 

 

Figure 7: ANSI T1.102 Measurement Selections 
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Tests 

Eight tests are available using this application.  

Note: Available tests depend on the selected standard and data rate. See ANSI 
T1.102 Data Rates and Tests or see ITU-T G.703 Data Rates and Tests. 
 

 

Table 8: Select Test Area Options 

T est D escrip tio n   
P u lse  A m plitude  M easures  the  am plitudes  o f iso la te d  pos itive  and  nega tive  

pu lses  re la tive  to  the  zero  leve l o n  da ta  ra tes  tha t use  AM I 
cod ing .  P rec ise  techn iqu es  fo r pe rfo rm ing  these 
m easurem ents  vary be tw e en d a ta  ra tes  an d s tan dards .  
(B in ary o r pseud orandom  P R B S ) 

P u lse  Im ba lance 
V aria tion  

M easures  the  varia tion  o f pu lse  am plitudes  and w id ths  on  the  
D S 1 fo r th e  A N S I T 1 .102 s tandard  1 .544 M b/s  d a ta  ra te  o ver 
17  consecutive  b its .  (Idea lly th e  user sho u ld  p ro vide  a n  a ll 
1 's  s igna l b u t pse udo-random  sequences  a re  a lso  va lid .) 

P u lse  Im ba lance 
R atio  

M easures  the  ra tio  o f am plitudes  o f pos itive  and  nega tive  
iso la ted  pu lses . 

P u lse  S ym m etry C a lcu la tes  the  ra tio  o f pu lse  am plitu des  an d w id ths  o f pos itive  
and  neg ative  iso la te d  p u lse s  on  som e IT U –T  G .703  da ta  
ra tes  

P eak -P eak  M easures  the  am plitude  o f iso la ted  pos itive  a nd neg ative  
edges  

Z ero  Le ve l V erif ies  w hether the  m axim um  and m in im um  va lues  o f a  
log ica l zero  (such  as  n o  pu lse) a re  w ith in  10 %  o f the  n om ina l 
am plitude  

S pectra l P ow er D e term ines  w he ther a  com m unica tions  w a veform  is  w ith in  
the  spec tra l po w er leve l co ns tra in ts  se t by the  s tan dards  
N arrow band: M easures  tra nsm itted  po w er o f an  “a ll o nes” 
s igna l in  tw o frequenc y ban ds , each 3  kH z ” 1  kH z; the  cente r 
frequenc ies  o f the  tw o  ba nds  a re  ha lf the  b it ra te  
(fundam enta l) and  the  b it ra te  (2 nd ha rm on ic ); the  po w er a t 
the  fund am enta l m ust fa ll w ith in  a  spec ified  range a nd the  
po w er in  the  2 nd h arm on ic  m ust be  low er than  the  
fundam enta l b y a t leas t a  spec ified  am ount 
W ideband: M e asures  th e  to ta l po w er be low  a  des ign ated  
bandw id th  as  sp ec ified , usua lly in  a  fram e s truc tu re  (no t an  
“a ll ones” s ig na l); the  ba ndw id th  lim it is  th ree  to  four tim es  the  
b it ra te  

M ask  T akes  m easurem ents  based  on  the  pu lse–  or eye –sha ped 
m ask  assoc ia ted  w ith  the  se lec ted  da ta  ra te  a nd the  se tup  
param ete rs  tha t correspon d w ith  the  se lec ted  tes t 

 
 

12       TDSCPM2 Communication Pulse Measurements Application 
 



 
               Operating Basics 

     

Configuring Measurements 

The Setup parameters section of the Measurements: Config panel allows you to 
configure your measurements. The Configure Menu Options table lists all of the 
setup options with a brief description of each. 

Note: Setup options vary by data rate for the Mask test. See ITU-G.703 data 
rates and Mask Options and ANSI T1.102 Data Rates and Tests. 
 

Table 9: Configure Menu Options and Mask Symbol Options 

Option Description 
Input Selects the input channel for the measurement 
Num Avg Specifies the number of waveform acquisitions that are 

averaged prior to testing 
Autofit Mode Allows the instrument to zero in on a passing mask 

solution based on an iterative movement along the 
horizontal and vertical axis 

*Mask Margin Controls how much tolerance is permitted in providing a 
passing solution. 

Mask Symbol See table below 
*If margins are not equal, the results are shown in yellow. 
 
 
Mask Symbol Options 
 
Selections Data Rate 
Eye or Pulse STS-1 51.840 
Binary 0 or 
Binary 1 

E4, STM1-E 

Standard or 
Max Output 

STS-3, DS4NA 
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Figure 8: Configure Autofit Menu 

 

Taking Measurements 
The TDSCPM2 application will override user-specified trigger and time base 
settings before performing any of the measurements. 

Note: Remember to select Reset to set the results to zero if you change the 
oscilloscope Vertical or Horizontal time settings between measurements. 
 

Lower bit rate mask tests utilize math channel 1 to provide a filtered signal  
(350 MHz Low Pass filter) for testing. Due to this filtering, the signal appears on 
the math channel (M1). 

Performing Compliance Tests 

To acquire data from waveforms, follow these steps: 

1. Select a Sequence mode (Free-run or Single).   

Note: The Sequence Control menu is always accessible in the right side of the 
application display. 
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2. Press the Run button icon  to start the acquisition. 

 

Note: Do not change oscilloscope settings while taking a measurement, since this 
can cause an invalid measurement. 
 

Analyzing the Results 

The application displays the selected pulse-mask pattern with the 
communications waveform for visual analysis and can display the results from 
selected measurements as statistics. You can also log the data to a 
RESULTS.CSV file for viewing with a spreadsheet, database, or data analysis 
program. 

  

   Figure 9: Pulse-Mask Pattern 
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Figure 10: CSV Spreadsheet Example 
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Figure 11: Results Readout 

 

Clearing Results 

To clear results, select the Reset button on the Sequence Control menu. You do 
not have to wait for a measurement to complete to clear the results. 

 

 

      Figure 12: Sequence Control Menu 
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Table 10: Sequence Control Menu Options 

Option/button (icon) Description 
Mode    
 Single  

 
Performs measurements on a single acquisition 
and stops 

 Free Run Repeatedly acquires the input waveform(s) and 
takes measurements 

Start/Continue button  Starts to take measurements from the input 
waveform(s); when paused, continues taking 
measurements 

Pause button Pauses and resumes when you select the 
Continue button or stops when you select the 
Stop button 

Stop button Stops taking measurements 
Reset button Resets all result values to zero 
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Saving Results to a File 
You can save (log) the results for all active measurements to a data log file. 

Logging 

This type of logging saves the statistical results and the individual result points of 
active measurements to a data log file. To access the Statistics Log menu, go to 
the Log menu in the menu bar and select Statistics. 

Table 11: Log: Options and Buttons 

Option/button Description 
Logging Enables the application to save the measurement results 

for all active measurements, as well as the individual 
results to a data log file 

Clear    Clears the data log file; you must turn off the logging before 
you can clear the contents of the data log file 

Log File Name: 
Browse  

Allows you to select the directory in which to save the data 
log file and to enter a name for the file; the extension must 
be .csv 

 
 

Table 12: Log Menu Parameters 

Parameter Selection Default setting 
Logging On, Off Off 
Clear    None     
Log File Name: 
Browse  

Any file C:\TekApplications\tdscpm2\logs
\results.csv 

 
 

Data Log File Format 

The data log file consists of one header row and rows of logged information. The 
header row contains the application name, the version number of the application, 
and the date and time on which the file was created.  

The remaining rows contain information for the measurements. The information 
is in the following order:  

Application name  Version Number  Date  Time 
Standard  Data Rate  Test   Result  Value  Hit Count  Unit  Result  Remark  Date   Time 

 

Figure 13: Data Log File Format 
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Note: If you are using a GPIB program to execute the application, such as 
automated test environments, you can add your own annotation through the 
logAnnotate GPIB command. You can add information consisting of up to 20 
characters; the custom information will appear as the last column in the 
individual result records of that acquisition. 
 

Viewing a Data Log File 

You can view the .csv data log file (comma separated variable format) in a 
spreadsheet, database, text editor or data analysis program for further analysis.  

If you take different measurements and store them in one data log file, you can 
group the measurements by sorting them in a program on a personal computer.  

 

Saving and Recalling Setups 
You can use the File menu to save and recall different configuration setups. To 
access the Save and Recall options, go to the File menu in the menu bar and 
select Save or Recall.  

Note: Do not edit the .ini or the .set files, or recall setup files not generated by 
the application, since this can cause the application to become unstable. 
 

The File menu Save/Recall function includes the settings of the oscilloscope 
application. When you exit the application, you can choose whether to restore the 
settings of the oscilloscope to those present before starting the application. 

     Table 13: Save/Recall Measurement Options 

Option Description 
Recall Default Recalls the initial application state. 
Recall Allows you to select a saved application setup file 

for recall.  Also restores the application to the state 
prior to saving the setup file. 

Save* Allows you to select a file name in which to save the 
current state of the file. 

Recently Recalled Select from a list of the four most recently recalled 
setup files to recall the setup. 

Recently Saved Allows you to select and save a file from a list of the 
four most recently saved files.  

*Also saves a scope setup file of the same name. 
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Saving a Setup 

To save the application settings to a setup file, follow these steps: 

1. Select the File menu. 

2. Select the Save option. 

 Note: The application also saves the oscilloscope setup to a ".set" file when you 
save an application setup. Both the application ".ini" file and oscilloscope ".set" 
files have the same file name. 
 

 

Figure 14: Save Setup Step 1 

 

Figure 15: Save Setup Step 2 
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Recalling a Saved Setup 

To recall the application settings from a saved setup file, follow these steps: 

1. Select File > Recall. 

2. Select the directory in which the setup file is located. 

3. Select or enter a setup file name. 

4. Select Recall. 

Note: The application also recalls the oscilloscope setup from a .set file when 
you recall an application setup. 
 

 Recalling the Default Setup 

To recall the application settings from the Default setup file, follow these steps: 

1. Select File > Recall Default from the menu.  

You will receive the message, "Default State Recalled Successfully!" 

2. Select OK to return to main screen. 

 

 

Figure 16: Recall Default Menu 

22       TDSCPM2 Communication Pulse Measurements Application 
 



 

     

  

Tutorial 

This tutorial teaches you how to set up, take measurements, and view the results 
on the display or from a data log file. In addition, it teaches you how to stop and 
return to the tutorial.  

Before you begin the tutorial, you need to do the following tasks: 

� Connect to a communication signal 

� Set up the oscilloscope 

� Start the application 

Connecting to a Communications Signal 
Connect a communications signal on the SUT to CH 1 on the oscilloscope as 
described in connecting to a system under test (SUT).  

Note: Be sure to power on the SUT. 
 

Setting Up the Oscilloscope 
To set up the oscilloscope, follow these steps: 

1. Push Default Setup. 

2. Push Autoset. 

3. Verify that your signal of interest is on the screen. 

 

Starting the Application 
To perform the tutorial, the TDSCPM2 application must be installed on the 
oscilloscope. See the Optional Applications Software on a Windows-Based 
Oscilloscope Installation Manual. 

To start the application, follow these steps: 

1. Select File > Run application in the oscilloscope menu bar. Then select 
Communications Pulse Measurements 2, or  
Select App > Communications Pulse Measurements 2, or 
Select Analyze > Communications Pulse Measurements 2. 
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2. The application starts and displays the opening or Measurements: Select 
menu. 

3. Choose the standard and data rate that corresponds to the SUT. 

 

 

Figure 17: Measurement Select Menu 

Taking a Measurement 
This lesson teaches you how to use the TDSCPM2 application to take 
measurements from a standard communications signal. 

To take a measurement, follow these steps: 

1. Be sure that you are displaying a signal on the oscilloscope. 

2. Select Test > Mask. 

3. Select Measurements > Config > Input > Ch1 (already set as default). 

4. Press  to start the Acquisition. 

Note: The TDSCPM2 application properly aligns the pulse-diagram of the 
communications signal over the selected pulse-shaped mask pattern. 
 

5. Select another test and repeat step 3. 

Note: The Results page accumulates successive test results. 
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Saving Results to a Data Log File 
To save the measurement results to a data log file, follow these steps: 

1. Go to the Log menu in the menu bar and select Statistics.  

 

Figure 18: Set Up Log File 

2. Select Logging On. 

3. Press  to start the acquisition. 

4. Select Logging Off before viewing the data log file. 

5. Exit the application. 

 

Viewing a Data Log File 

You can view the .csv data log file (comma separated variable format) in a 
spreadsheet, database, text editor or data analysis program for further analysis.  

If you take different measurements and store them in one data log file, you can 
group the measurements by sorting them in a program on a personal computer.  

Note: You can use Notepad or WordPad to view quickly the results in the data 
log file. 
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Stopping the Tutorial 
If you need more than one session to complete the tutorial lessons, you can stop 
the tutorial and return to it another time.  

To save the application setup and stop your session, refer to Saving a Setup. 

Returning to the Tutorial 
To return to the tutorial setup, you can start the application and then recall the 
saved setup. To recall the application setup, refer to Recalling a Saved Setup. 
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Menus and Parameters 
This section describes the TDSCPM2 application parameters, and includes the 
menu default settings. You should refer to the user manual for your oscilloscope 
for operating details of other controls, such as front-panel buttons.  

Refer to the GPIB Programming section of this Help file for a complete list of the 
GPIB Control Parameters. This topic includes a complete list of the GPIB 
commands along with the arguments, variables, and variable values that 
correspond to the TDSCPM2 parameters. 

View Menu 

There are no parameters for the View menu. 

Help Menu 

There are no parameters for the Help menu. 
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File Menu 

You can perform basic operations such as opening, closing, saving and printing 
of files from the File menu.  

 
Table 14: File Menu Parameters  

Option Description Default Setting 
Recall 
Default 

Recalls default state  

Recall Browse and select file 
to recall application 
settings 

C:\TekApplications\tdscpm2\setup\
setup1.ini 

Save Save current 
application settings 

C:\TekApplications\tdscpm2\setup\
setup1.ini 

Recently 
Recalled 

Select from a list of 
recently recalled setup 
files 

None 

Recently 
Saved 

Save again by selecting 
from a list of recently 
saved files 

None 

Minimize Minimizes the 
application to a button 
on the Windows 
taskbar 

None 

Exit Exit the application None 
 
 
  

 

 

Figure 19: File Menu 
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Measurements Menus 

There are two Measurements menus: 

� Measurements Select  

� Measurements Configure  

 

Figure 20: Measurement Select Menu 

Standard Area 

The Standard area includes the following selections: 

� Data Rate Area, ITU  

� Data Rate Area, ANSI  

Data Rate Area, ITU 

The ITU-T G.703 standard data rate includes the following selections:  

� E1 2.048 Mb/s Coax Pair 

� E1 2.048 Mb/s Sym Pair 

� E2 8.448 Mb/s 

� E3 34.368 Mb/s 

� E4 139.26 Mb/s 

� STM–1E 155.52 Mb/s 

The application takes measurements based on these data rates as defined in the 
ITU-T Recommendation G.704, General Aspects of Digital Transmission 
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Systems, ITU-T G.703 document. Data Rate Menu Options for ITU-T G.703 
Standard lists the location of the data rate definitions in the standard. 

Data Rate Area, ANSI 

The ANSI T1.102 standard data rate includes the following selections: 

� DSI 1.544 Mb/s 

� DS3 44.736 Mb/s 

� DS4NA 139.26 Mb/s 

� STS-1 51.840 Mb/s 

� STS-3 155.52 Mb/s 

The application takes measurements based on these data rates as they are defined 
in the American National Standard for Telecommunications - Digital Hierarchy - 
Electrical Interfaces, ANSI T1.102-1993 document. Data Rate Menu Options for 
ANSI T.102 Standard lists the location other data rate definitions in the standard. 

Test Area, ITU 

 The ITU-T G.703 data rates includes the following test selections: 

� Pulse Amplitude (only for AMI signals) 

� Peak-Peak (only for CMI signals) 

� Pulse Symmetry 

� Zero Level 

� Mask 

Note: Available tests depend on the selected standard and data rate. See ITU-T-
G.703 Data Rates and Tests for test selections. 

 
Test Area, ANSI 

The ANSI T1.102 data rates include the following test selections: 

� Pulse Amplitude 

� Pulse Imbalance Variation 

� Pulse Imbalance Ratio 

� Spectral Power 

� Mask 
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Figure 21: Measurement Config Menu 

 

Table 155: Sequence control Menu 

Option/button (icon) Description 
Mode    
 Single  

 
Performs measurements on a single acquisition 
and stops 

 Free Run Repeatedly acquires the input waveform(s) and 
takes measurements 

Start/Continue button  Starts to take measurements from the input 
waveform(s); when paused, continues taking 
measurements 

Pause button Pauses and resumes when you select the 
Continue button or stops when you select the 
Stop button 

Stop button Stops taking measurements 
Reset button Resets all result values to zero 
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 Figure 22: Sequence Control Menu 

 

Table 16: Configure Menu Parameters 
 
Parameter Selections Default setting 
Input Ch1, Ch2, Ch3, Ch4 Ch1 
Num Avg 2 through 10,000 16 
Mask Symbol Binary 0, Binary 1 Binary 0 
Mask Time Base Adj Yes, No No 
Mask Offset Adj Yes, No No 
Mask Margin  –50.0 to 50.0 V, see Mask 

Margin Limits 
0 V 

Mask Time Base Full Mask, Time Details Full Mask 
Max Symbol Max Output (default), 

Standard 
No 

Mask Symbol Pulse, Eye Pulse 
 

 
 

Select Menu Parameters 

Mask 

The Mask measurement checks the communications signal to see if it conforms 
to corresponding mask parameters. This application uses Option SM (Serial 
Mask) on the oscilloscope to perform this test. 

The application offers the following parameters that you can use to customize the 
Mask test. 
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           Table 17: Mask Parameters 

Parameter Description 
Vertical  Select Autofit Mode On button to set up autofit 

mode. Then select Configure button to  access 
the vertical setting. 

Horizontal  Select Autofit Mode On button to set up autofit 
mode. Then select Configure button to  access 
the horizontal setting. 
See Autofit dialogue box. 

Mask Margin  
 
 
 

The application uses this parameter to relax or 
restrict the signal space for a selected mask. A 
positive margin causes the signal space to be 
smaller and makes the Mask test harder to pass. 
A negative margin causes the signal space to be 
larger and makes the Mask test easier to pass.  

 
 
 

 

 

Figure 23: Configure Autofit Menu 

 

Mask Margin Limits 

The next table lists the upper and lower masks margins for each standard and 
data rate. 

Note: The values for all fields default to zero. 
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Table 168: Mask Margin Limits 

Standard and data rate Upper margin Lower margin 
ITU–T G.703   
 E1 Coax 6.3% -33% 
 E1 Sym 6.3% -33% 
 E2 6.3% -33% 
 E3 6.3% -33% 
 E4 (Binary 0) 6.3% -33% 
 E4 (Binary 1) 6.3% -33% 
 STM–1E (Binary 0) 6.3% -33% 
 STM–1E (Binary 1) 6.3% -33% 
ANSI T1.102   
 DS1 6.3% -33% 
 DS3 6.3% -33% 
 DS4NA (Standard) 50% -50% 
 DS4NA (Max Output) 50% -50% 
 STS–1 (Eye) 50% -50% 
 STS–1 (Pulse) 6.3% -33% 
 STS–3 (Standard) 50% -50% 
 STS–3 (Max. Output) 50% -50% 
 

 

 

 

Figure 24: Configure Mask Margins 
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Additional Mask Parameters 

The Mask Symbol parameter for the ITU-T G.703 E4 and STM-1E data rates 
offers two kinds of masks: Binary 0 or Binary 1.  You can select the mask in the 
Configure Measurement menu. 

The Mask Symbol parameter for the ANSI T1.102 DS4NA and STS-3 data rates 
and offers two kinds of masks: Max Output and Standard.  

The Mask Symbol parameter for the ANSI T1.102 STS-1 data rate offers two 
kinds of masks: Eye and Pulse.  

 

 

Figure 25: STS1 Eye-Pulse Selection 

 

Log Menu 

Table 19: Log Menu Parameters 

Parameter Selection Default setting
Logging On, Off Off
Clear None
Log File Name:
Browse

Any file C:\TekApplications\tdscpm2\logs\results.csv
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Measurement Algorithms 
The TDSCPM2 application may display a specified pulse-mask pattern behind 
the communications signal being acquired. The application also takes 
measurements from the communication signal. 

The application performs the measurement according to the following algorithm: 

1. Acquires the communications signal. 

2. Performs the measurement or senses mask hits. 

3. Uses the results in the Results readout, or saves the results to a data log file. 

Oscilloscope Setup Guidelines 

For all measurements, use the following guidelines to set up the oscilloscope: 

1. The application will generally set the vertical settings at a pre-specified level 
in accordance to the standard being tested. 

2. The input power level must be less than 500 mW or 27 dBm. 

Measurements 

All communications signal measurements are based on the spectral power 
components, its amplitude, or the timing of edges within each acquisition. Pulse–
mask patterns are defined in the Standard and the Data Rate areas of the Select 
Measurement Menu. 

Pulse Amplitude 

This measurement applies to ANSI T1.102, DS1 and DS3 data rate, and to the 
ITU-T G.703, E1, E2 and E3 data rates. 

The Pulse Amplitude test measures the amplitude of isolated positive and 
negative pulses. The test is performed on standards that use AMI line coding. 
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The application calculates the measurement using the following equation: 

PA = Avg (PAIsolated +1, Abs(PAIsolated – 1)) 

Where:  

PA is the amplitude of the pulse 

Avg is the average of the two input parameters determined by 
adding the inputs and dividing it by two 

PAIsolated +1 is the result of the Measure  High measurement 
on the oscilloscope of the Isolated +1 signal 

PAIsolated – 1 is the result of the Measure  Low measurement 
on the oscilloscope of the Isolated –1 signal 

Abs (PAIsolated – 1) is the absolute value of its input parameter 

Peak-Peak 

This measurement applies to ITU-T G.703, E4 and STM-1E data rates. 

The Peak-to-Peak test measures the amplitude of isolated positive and negative 
edges. This test is performed on standards, which uses CMI line coding. 

The application calculates the measurement using the following equation: 

 PP = Result of the Measure  PK2PK measurement on the oscilloscope  

Where: 

PP is the peak-to-peak amplitude of the pulse 

Pulse Imbalance Variation 

This measurement applies to ANSI T1.102, DS1 data rate. 

This measurement is the maximum variation of the pulse amplitude and pulse 
widths based on an All 1 signal. The application assumes that the signal is an All 
1s data stream but does not attempt to validate this. 

The application calculates the measurement using the following equations: 

PIV(PK2PK Amplitude) = Absolute Average (pkpkPositiveAmplitude, 
pkpkNegativeAmplitude) 

PIV(PK2PK Pulse Width) = Absolute Average (pkpkPositivePW, 
pkpkNegativePW)  

Where:  

Absolute Average returns the average of its input ignoring the 
sign 

pkpkPositiveAmplitude is the Peak-to-Peak vertical histogram 
variation of the Positive 1 of an AMI 17 consecutive 1s signal 
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pkpkNegativeAmplitude is the Peak-to-Peak vertical histogram 
variation of the Negative 1 of an AMI 17 consecutive 1s signal 

 pkpkPositivePW is the Peak-to-Peak horizontal histogram 
variation of the Positive 1 of an AMI 17 consecutive 1s signal 

pkpkNegativePW is the Peak-to-Peak horizontal histogram 
variation of the Negative 1 of an AMI 17 consecutive 1s signal 

Pulse Imbalance Ratio 

This measurement applies to ANSI T1.102, DS3 data rate. 

The Pulse Imbalance Ratio measurement is the ratio of positive and negative 
isolated pulses. 

The application calculates the measurement using the following equation: 

PulseImbalance Amp ratio = meanPPA/meanNPA 

Where:  

meanPPA is the mean value of the vertical histogram placed on 
the positive isolated pulse  

meanNPA is the mean value of the vertical histogram placed on 
the negative isolated pulse  

Pulse Symmetry 

This measurement applies to ITU-T G.703, E1, E2, and E3 data rates. 

The Pulse Symmetry measurement is the amplitude and width symmetry of AMI 
signals between positive and negative pulses. 

The application calculates the measurement using the following equation: 

PulseSymmetry(Amp Ratio) = meanPPA/meanNPA  

PulseSymmetry(PW Ratio) = meanPositivePW/meanNegativePW 

Where: 

meanPPA is the mean value of the vertical histogram placed on 
the positive isolated pulse 

meanNPA is the mean value of the vertical histogram placed on 
the negative isolated pulse  

meanPositivePW is the positive width of Isolated plus 1 signal  

meanNegativePW is the negative width of Isolated minus 1 
signal  
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Zero Level 

This measurement applies to ITU-T G.703, E1, E2, and E3 data rates. 

The Zero Level measurement verifies if the maximum and minimum values of a 
logical zero (no pulse) signal is within the expected limits for the signal. 

 
The application calculates the measurement using the following equation: 

ZeroLevel = Average(ZeroLevelMax, ZeroLevelMin)  

Where:  

ZeroLevelMax is equal to the average of Max1 and Max2 

ZerolevelMin is equal to the average of Min1 and Min2 

Average is the average of the two input parameters determined 
by adding the inputs and dividing it by two 

Max1 is equal to Mean1 + PeakPeak1/2  

Min1 is equal to Mean1 – PeakPeak1/2 

Max2 is equal to Mean2 + PeakPeak2/2  

Min2 is equal to Mean2 –PeakPeak2/2 

Mean1 is the mean value of a vertical histogram placed on an 
Isolated + 1 pulse 

PeakPeak1 is the peak-to-peak value of a vertical histogram  
placed on an Isolated + 1 pulse 

Mean2 is the mean value of a vertical histogram placed on an 
Isolated –1 pulse 

PeakPeak2 is the peak-to-peak value of a vertical histogram 
placed on an Isolated –1 pulse 
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Spectral Power 

This measurement applies to ANSI T1.102, DS1, DS3, STS-1, STS-3 and 
DS4NA data rates. 

The Spectral Power measurement determines whether a communications signal is 
within the spectral power limits set by the ITU-T G.703 or ANSI T1.102 
standards. To calculate the spectral power, the application uses the FFT (Fast 
Fourier Transform) function of the oscilloscope to convert a time domain signal 
into a frequency domain signal. 

The application calculates the measurement using the following equation: 

∑
−

=
11 N

XW
=Ω 0

2 2

k
kN  

 

Where: 

W is the power of the spectrum 

W is the characteristic impedance of the signal being measured, 
and not the 50W of the oscilloscope input; the adapter provides 
the proper termination and voltage translation so the application 
displays the voltage level as if the input of the oscilloscope was 
75/100/110/120 W. 

N is the number of waveform samples 

For the spectral display, the oscilloscope uses the following equation: 

N
XkA 2  

 

Where: 

A is the window adjustment scalar and the 2  accounts for both 
the + and – frequencies; A equals 1 for a rectangular window 

This means (ignoring A for the moment) that the oscilloscope calculates the 
spectral power using the following equation: 
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Narrow Band 

This measurement applies to ANSI T1.102, DS1 data rate. 

The Narrow Band measurement checks the transmitted power in the 3 kHz and  
1 kHz frequency bands. The center frequencies of the two bands are half the bit 
rate (fundamental) and the bit rate (2nd harmonic). The power at the fundamental 
must fall within a specified range. The power in the second harmonic must be 
lower than the fundamental by a specified amount or more. The measurements 
are made using an All 1s signal. The application assumes that the signal is an All 
1s data stream but does not attempt to validate this. 

For narrow-band power measurements, you must use a window to correct the 
power calculation.  

The application uses a Hanning FFT window, which results in multiplying the 
power by a factor of 2/3rds as shown in the following equation:  

Let:  

              M = number of harmonics to include 

              m :=  0 ... M - 1 

Let f be an array of frequencies of the fundamental and each of the possible 
harmonics. Then m is an index to select a harmonic. This array was built by 
measuring the maximum amplitude of the spectrum at the frequency locations 
where the harmonics occur. 

The calculation for power at a given point in the spectrum is shown below with 
the function P(f): 

( ( ))( )
R

fP := fX 2|
 

 Where: 

 P(f) is the power of a given point in the spectrum. 

 X(f) is a sample of the complex spectrum from an FFT at the frequency, f. 

 R is the reference resistance the voltage is assumed to be across.   

 A value of 50 ohms is used by the measurement.   

Compute power of the fundamental:  

 P1 := P(f1)                        
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Compute power of the second harmonic: 

P2 := P(f )  2

Compute the difference in dB between fundamental and second harmonic: 

d:= 10 log (P1) − 10 log (P2)                       
If d > 29 dB, then pass. 

Wide Band 

This measurement applies to ANSI T1.102, DS3, STS-1, and DS4NA data rates. 

For this measurement, the power, P, is the total power in the fundamental and 
harmonics of the signal.                   

( )∑=
m

mfPP :  

 

Where m takes on values of m = 1 ... M -1 with M being the desired number of 
harmonics to include. The fundamental is at m = 1. 
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GPIB Programming 

You can use GPIB command syntax in your GPIB program to do the following 
tasks: 

� Start the application 

� Recognize an active application with GPIB protocol 

� Program and read application setup parameters 

� Sequence Measurements 

� Read measurement results 

To use GPIB commands with your oscilloscope, you can use the following 
reference materials: 

� The tdscpm2ctrl.c file on the oscilloscope hard drive (located in the 
c:\program files\tekapplications\tdscpm2 directory) and on the optional 
applications compact disc contains an example of a GPIB program that can 
execute the application 

� The Guidelines to GPIB Programming section for guidelines to use while 
designing a GPIB program 

� The Parameters Reference section for incremental units and default values 
of TDSCPM2 parameters 

� The programmer information in the online help of your oscilloscope 

You should be familiar with the following terms when using GPIB command 
syntax: 

Description: Gives the function of the command, conditions of its use, and its 
interactions with other commands.  

Syntax: Gives the valid select and query command forms. The required 
arguments are listed in their proper order. For example, in the syntax definition, 
PATH= <Ad><Ars>  

The arguments <Ad> and <Ars> are required in the order indicated. 

Arguments: The arguments to a command are defined along with their range of 
values.  

Returns: Defines the data returned in response to a command query.  
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Starting the Application in GPIB 
To start the TDCPM2 application, you must send the oscilloscope the following 
GPIB command: 

application:activate "Communications Pulse Measurements 2" 

  
Variable: Value TDS Command 

VARIABLE: VALUE TDS COMMAND accepts string arguments for a control 
or data variable and a value to which to set the argument.   

Syntax: VARIABLE: VALUE “<variable name>”,“<variable value>” 
 

Note: The arguments <variable name> and <variable value> are required in the 
order indicated. 
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  Table 17: Variable: Value TDS Command Arguments and Queries 

Variable name Variable value Function Query form 
application exit Terminates the active 

application 
Returns a string that 
corresponds to the name 
of the active application 

logAnnotate* Any string from one to 
twenty characters 

Provides custom 
annotation to the data 
log file.  Sets the string 
to be appended to result 
point logged 

Returns the current 
LogAnnoate string 

logger {Reset} Clears the current data 
log file 

No query form 

loggerDestination Any string from one to 
eight characters from A 
to Z and/or zero to nine 

Sets the data log file 
name (name should not 
include .ini extension) 

Returns the data log file 
name 

loggerState {On, Off} Sets the state of the 
logger function to on or 
off 

Returns the state of the 
logger function 

recallName  Any string that uses 
one to eight characters 
from A to Z and/or zero 
to nine 

Sets the recalled setup 
file name 

Returns the recall setup 
file name 

saveName Any string from one to 
eight characters from A 
to Z and/or zero to nine 

Sets save setup file 
name 

Returns the save setup 
file name 

setup {Default, Recall, Save} Causes a save or recall  Returns the selected 
value of Default, Recall or 
Save 

sequencerMode {Free Run, Single} Sets the sequencer 
mode 

Returns the sequencer 
mode 

sequencerState {Ready, Paused, 
Sequencing} 

Sets the state of the 
sequencer 

Returns the state of the 
sequencer 

* Custom annotation in the data log file is only available through GPIB execution of the 
application. 

  

 

Table 21: Measurements Results Queries 

Variable name Function
error Returns the error dialog box, if one exists, associated with

the last measurement
resultValue Returns the result of the last test  in the Name, Value,

Remarks format
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GPIB Program Example 
The programming example shows how a GPIB program might execute the 
application to do the following tasks: 

� Start the application 

� Select a data rate 

� Select a test 

� Enable the logger 

� Take a measurement 

� Check for an error 

� Exit the application 

  

Guidelines to GPIB Programming 
Your GPIB program should comply with the following guidelines: 

� Turn off the GPIB response headers with the “HEADER OFF” command; 
refer to the programmer information (in online help) for your oscilloscope 

� The application startup must complete before sending additional GPIB 
commands to the application (see example) 

� The measurements cycle must complete before data is queried (see example) 

� The error variable should be checked to ensure that an error has not occurred 
because of a measurement command problem 

 

Note: You should allow at least a three- second delay in your program between 
specifying a test. If there is not enough time between data rate and test selections, 
the application reverts to the default test.  
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GPIB Program Example 

  

/*  TDSCPM2Validat */ 

 

/* 
===========================================================
========= 

 *  Note: In order to build the .exe correctly, copy gpib-
32.obj from 

 * "C:\Program Files\National 
Instruments\GPIB\NI488\LangInt\C\" to the local workspace. 

 

When executed, this program should operate as follows. 

Test Result: "Mask 0.0 PASS" 

 

Recalling setup file ds1pa 

Do a single test... 

Test Result: "Pulse Amplitude 3.05615V PASS" 

 

Recalling setup file ds1mask 

Do a single test... 

Test Result: "Mask 0.0 PASS" 

 

Recalling setup file ds1pa 

Do a single test... 

Test Result: "Pulse Amplitude 3.054750003V PASS" 
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Recalling setup file ds1mask 

Do a single test... 

Test Result: "Mask 0.0 PASS" 

 

Recalling setup file ds1pa 

Do a single test... 

Test Result: "Pulse Amplitude 3.05475006V PASS" 

 

  */  #include <string.h> 

#include <stdio.h> 

#include <sys/timeb.h> 

#include <windows.h> 

#include "C:\Program Files\National Instruments\NI-
488.2\Languages\DLL Direct Entry\decl-32.h" 

 

int start_application (int scope);  

int do_single_test (int scope); 

void setupAndExecuteTest (char * Standard, int Scope); 

  

void main (void) 

{ 

 int scope; 

 int status;  

  

/* 

 * Open session to TDS Scope with for IBIC 

 */ 

48       TDSCPM2 Communication Pulse Measurements Application 
 



 
                       GPIB Programming 
        

 scope = ibfind ("DEV1"); 

 status = ibtmo (scope, T10s); 

 if (start_application(scope)){ 

  while (1) { 

            

/* DS1 testing 

 * The way this works, is it recalls an application setup 
file “ds1mask” which the 

 * The user has setup before hand, and initiates a run 
state.  After the application returns 

 * To the Ready state we then query the measurement results 
string, and print them.  

 * This program simply cycles between a ds1mask setup and a 
ds1pa (pulse amplitude  

 * test). 

 */ 

 

  setupAndExecuteTest("ds1mask", scope); 

  setupAndExecuteTest("ds1pa", scope); 

  } 

 } 

} 

 

void setupAndExecuteTest(char * SetupName,int scope) 

{ 

 char read_buffer [100] = ""; 

 char write_buffer [100] = ""; 

 int status; 

TDSCPM2 Communication Pulse Measurements Application                                                                               49 
 



 
GPIB Programming 

 

  

/*  

 * In order for this program to work correctly, the 
instrument should be in "Header Off" state 

 */ 

 sprintf (write_buffer, "%s", "Header Off"); 

 status = ibwrt (scope, write_buffer, strlen 
(write_buffer));  

   

/* 

 * Recall the specified system setup file   
"recallName","ds1pmpiv"  "setup", Recall" 

 */ 

 

  printf ("Recalling setup file %s\n",SetupName); 

 

  sprintf (write_buffer, "%s%s%s", 
"Variable:value \"recallName\",\"",SetupName,"\""); 

  status = ibwrt (scope, write_buffer, strlen 
(write_buffer));  

 

  sprintf (write_buffer, "%s", "Variable:value 
\"setup\",\"\""); 

  status = ibwrt (scope, write_buffer, strlen 
(write_buffer));  

 

  sprintf (write_buffer, "%s", "Variable:value 
\"setup\",\"Recall\""); 

  status = ibwrt (scope, write_buffer, strlen 
(write_buffer));  
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/* 

 * Do a single test 

*/ 

  if (do_single_test(scope)){ 

    

/* 

 * Query test result 

 */ 

   sprintf (write_buffer, "%s", "Variable: 
value? \"resultValue\""); 

   status = ibwrt (scope, write_buffer, 
strlen (write_buffer));  

   status = ibrd  (scope, read_buffer, 
sizeof (read_buffer)); 

   if (ibcnt != 4) {    

/* It's not an empty string */ 

 

    read_buffer [ibcnt] = 0; /* 
Get rid of extra characters */ 

    printf ("Test Result: %s\n", 
read_buffer); 

   } 

   else{ 

    printf ("*** Computation Error 
***\n"); 

   }  

  }  
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} 

 

/*---------------------------------------------------------
---------------------- 

 * Function: start_application 

 * Argument: scope 

 * Return:   1 if success, 0 otherwise 

 *  

 * This function starts the application and confirms the 
completion of startup 

*/ 

 

int start_application(/* in */ int scope) 

{ 

 char read_buffer [100]; 

 char write_buffer [100]; 

 char app_name[30] = "\"tdscpm2\"\n";   

 int status; 

 int timer = 0; 

 int i = 0; 

 

     /* 

  * Has application already been started? Lets check 
first. 

 */ 

 sprintf (write_buffer, "%s", "Variable: value? 
\"application\""); 

 status = ibwrt (scope, write_buffer, strlen 
(write_buffer));  
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 status = ibrd  (scope, read_buffer, sizeof 
(read_buffer)); 

 read_buffer [ibcnt] = 0; /* Get rid of extra 
characters */ 

  

/* if return value from application query is tdscpm2 then 
we are already running */ 

 if (strcmp(app_name, read_buffer) == 0){ 

  printf ("Application %s is already 
running\n",app_name); 

  return 1;  /* Application is running, don't 
need to do anything */ 

 } 

 /* 

  * If application is not started up, start it and 
wait for application to completely  

  * start up 

 */ 

 

sprintf (write_buffer, "%s", "Application:activate 
\"Communications Pulse Measurements 2\""); 

status = ibwrt (scope, write_buffer, strlen 
(write_buffer));  

printf ("Starting application, please wait...\n"); 

while (strcmp(app_name, read_buffer)!= 0){  

 timer = timer + 1; 

 if (timer > 30) { /* The application normally take 24 
seconds to start up */ 

  printf ("***Application start up time 
out***\n"); 
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  return 0; /* Something is wrong if 
application does start up in 30s */ 

  } 

  sprintf (write_buffer, "%s", "Variable: value? 
\"application\""); 

  status = ibwrt (scope, write_buffer, strlen 
(write_buffer));  

  status = ibrd  (scope, read_buffer, sizeof 
(read_buffer)); 

 

  read_buffer [ibcnt] = 0;/* Get rid of extra 
characters */ 

  //printf ("Debug Msg: App = %s\n", 
read_buffer); 

     Sleep(1000); 

 } 

 /* Application start up! */ 

 

  return 1; 

} 

 

/*---------------------------------------------------------
------- 

 * Function: do_single_test 

 * Argument: scope 

 * Return:   1 if success, 0 otherwise 

 *  

 * This function does a single measurement and checks error 
status 

*/ 
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int do_single_test(/* in */ int scope) 

{ 

 char read_buffer [100]; 

 char write_buffer [100]; 

 char state[10] = "\"Ready\"\n";   

 int status; 

 int timer = 0; 

 int i = 0; 

  

 /* 

  *  Start measurement 

  */ 

 

     printf ("Do a single test...\n"); 

 sprintf (write_buffer, "%s", "Variable:value 
\"sequencerState\",\"Sequencing\""); 

 status = ibwrt (scope, write_buffer, strlen 
(write_buffer)); 

 Sleep(1000); 

     do{ 

  timer = timer + 2; 

  if (timer > 90) { /* Assuming a single test 
takes less than 60 seconds */ 

   printf ("***Test time out***\n"); 

   return 0; /* Something is wrong if 
sequencerState does not come back 

        * to Ready */ 
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  }      

  sprintf (write_buffer, "%s", "Variable:value? 
\"sequencerState\""); 

  status = ibwrt (scope, write_buffer, strlen 
(write_buffer));  

  status = ibrd (scope, read_buffer, sizeof 
(read_buffer)); 

  read_buffer [ibcnt] = 0; /* Get rid of 
extra characters */ 

     Sleep(3000); 

 }while (strcmp(state, read_buffer)!= 0); 

 

 /* 

  *  Though sequencerState Back to Ready, need to 
check the error variable 

  *  to make no error occur during measurement 

 */ 

 

 sprintf (write_buffer, "%s", "Variable:value? 
\"error\""); 

 status = ibwrt (scope, write_buffer, strlen 
(write_buffer));  

 status = ibrd  (scope, read_buffer, sizeof 
(read_buffer)); 

 if (ibcnt != 4){    /* error string 
is not empty */ 

  read_buffer [ibcnt] = 0; /* Get rid of 
extra characters */ 

  printf ("*** Error: %s ***\n", read_buffer); 

  return 0; 

 } 
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 return 1; 

} 

 

/* This is a support utility in case you are also 
controlling an Arbitrary Waveform Generator as 

 * part of a test setup. 

 */ 

 

int setupAWG(char * SetupName,int awg) 

{ 

 char write_buffer [100]; 

 int status; 

 

 sprintf (write_buffer, "%s", "Header Off"); 

 status = ibwrt (awg, write_buffer, strlen 
(write_buffer));  

 printf ("Setting up AWG with setup file 
%s\n",SetupName); 

 sprintf (write_buffer, "%s%s%s", "AWGControl:SREStore 
\"",SetupName,"\",\"MAIN\""); 

 status = ibwrt (awg, write_buffer, strlen 
(write_buffer)); 

 Sleep (2000); 

 

 sprintf (write_buffer, "%s", "AWGControl:RUN"); 

 status = ibwrt (awg, write_buffer, strlen 
(write_buffer)); 

 Sleep (1000); 
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 sprintf (write_buffer, "%s", "OUTPut1:STATe ON"); 

 status = ibwrt (awg, write_buffer, strlen 
(write_buffer)); 

 

 Sleep (1000); 

} 
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